Iframe soll sich der Höhe des Inhaltes anpassen

Hallo,

ich hab mal eine Frage:
Auf dieser Seite http://www.hess-objekt.de habe ich ein Newscript per Iframe eingebunden. Da sich die Höhe des Newsbereichs ja ständig ändert, möchte ich gerne, das sich die Iframe der Höhe des Newsbereichs anpasst. Ist das irgendwie realisierbar?
Für Eure Hilfe im Voraus besten dank!

16.12.2006 16:51


Am einfachsten mit der Implementierung des Newsbereichs mit SSI, PHP oder sonst irgendeiner serverseitigen Skriptsprache.

Per Javascript müsste sich u.U. was machen lassen, lohnt aber den Aufwand nicht.

16.12.2006 18:02


Also damit ich das richtig verstehe:
ich brauche also einfach die news.php mit dem include Befehl wie im Menübeispiel in meine index.htm Datei einfügen, in ein Tabellenfeld z. B.?
Ich kenne mit programieren leider nicht aus, deshelb frage ich so dumm.
Ich hab es auch schon mit Java versucht (http://www.dyn-web.com/dhtml/iframes/), aber das hat nicht hin gehauen.

Ich wäre dir für eine kleine Einweisung sehr dankbar.

Gruß
Bruce

17.12.2006 16:14


Ja.
Für PHP gibts unter http://de.php.net/include/ eine Anleitung.
Ggf. muss man die news.php noch anpassen, da man ja keine komplette HTML-Seite für den Output braucht.

17.12.2006 16:42


Hallo Mark,

so einfach war es dann wohl doch nicht. Ich habe diesen Code in meine index.htm eingefügt:

<!--#include virtual="/tsnews4/news.php" -->

das hat er erstmal al Kommetar angenommen. Dann hab ich die
<!-- -->
gelöscht, dann hat er auch nix angezeigt.

Was hab ich falsch gemacht?

18.12.2006 08:19


Hallo,

so einfach war es dann wohl doch nicht. Ich habe diesen Code in meine index.htm eingefügt:

<!--#include virtual="/tsnews4/news.php" -->

das hat er erstmal al Kommetar angenommen.

Dann mußt du deinen Apache so konfigurieren, dass er .htm-Dateien nach SSI-Anweisungen durchsucht.
Das geht z.B. mit den Zeilen
Options +Includes
AddOutputFilter INCLUDES .htm
in deiner .htaccess-Datei.

Grüße,
Moritz

18.12.2006 08:43


Hallo Moritz,

danke für deine schnelle Antwort. Auf meinem Webspace war keine
. htaccess Datei vorhanden, ich habe daher eine mit den Einträgen erstellt. Nach dem Hochladen, bekam ich dann beim Seitenaufruf einen 500- Fehler.

Gruß
Bruce

18.12.2006 09:15


Und was sagt die Logdatei? Sofern du Zugriff daraus hast natürlich...

Läuft da eine Apache 2.*? Wenn es ein älterer ist (1.3 oder so) kennt der noch keine OutputFilter.

Grüße,
Moritz

18.12.2006 09:24


Hallo Moritz,

eine Logdatei kann ich nicht finden. Ich habe aber mal nach Sriptsprachen gesucht die unserer Webspace unterstützt:

PHP5, PHP4, PHP3, Python & SSI, Perl

Von Apache hab ich nix gefunden, vielleicht weist du ja so, was Strato für eine Version hat. Wir haben das PowerWeb S Packet.

Ich kenne mich leider mit solchen Sachen nicht aus.

Gruß
Bruce

18.12.2006 10:04


www.hess-objekt.de läuft auf Apache/1.3.31 (Unix) - du kannst dir hier die Header-Daten inkl. Server-Angabe anzeigen lassen

Wie man einem Apache 1.3 beibringt, SSI auch auf htm DAteien anzuwenden, weiß ich allerdings auch nicht, ich verwende meist PHP Includes

18.12.2006 12:20 | geändert: 18.12.2006 12:22